OS-Browser Support Matrix for VPN Access

atNYULMC – Quick View Operating System/Browser Support Matrix for Remote Access

Last updated 10/11/2018
 

Please Note:

  1. Many of our atNYULMC offerings require the installation of the Citrix Client. It is recommended that you install this prior to signing in to atNYULMC. You can download the Citrix Client Updates (specific to your operating system) at http://atnyulmc.org/help-documentation/downloads.
  2. This Support Matrix indicates support only for the purposes of connecting to atNYULMC. Browser support by individual applications may vary.
  3. 64-Bit operating systems are supported using 32-bit browsers only.
  4. Google Chrome and any unlisted browsers are unsupported.
  5. If you need to install Firefox please download directly from this link.

Operating Systems

Browsers

Remote Access Option

Advanced

Basic

Windows 7, 8.1 and 10 *

Internet Explorer 11

Firefox

OS X El Capitan (10.11.x)

macOS Sierra (10.12.x)

macOS High Sierra (10.13.x)

Safari 11.x

Firefox

macOS Sierra (10.12.x)

macOS High Sierra (10.13.x)

macOS Mojave (10.14.x)

Safari 12.x

**

Firefox

*If the operating system/browser is unlisted it is unsupported. Additionally, Windows 8.1 is different from Windows 8.

**For Macs using Safari 12, the NYU Langone Advanced Access App will be used instead of a browser plugin.